Start a new topic

Miro suddenly won't work properly on my pc!! :(

It started a little while ago... Can't download anything on Miro, Miro keeps crashing on start but may work if I click on close the window and then on "try to restore the program" ... But then I can only watch already downloaded torrents, can't download anything new... I tried uninstall Miro, download and and install it again twice now but the same problem remains. I have Windows. Miro worked fine before, I don't know what happened. :(
I don't know what else to do but change to another torrent download software but I'd like to keep Miro... :(
I have an updated antivirous software and have scanned the pc but it didn't find anything.

3 people have this problem
1 Comment

I think I have the same problem. I am using Kubutu 13.10 Saucy Salamander. Miro launches and about two minutes after it starts updating podcasts the crash reporter comes up and says Miro crashed. Clicking on submit causes another crash which means the crash reporter can't be used!

 

Login or Signup to post a comment